Перейти к содержанию
Форумы
Mitya

Ошибка 400 BadRequest

Рекомендуемые сообщения

Поставили мониторинг на отдельный сервер.

 

настроили для начала три сервера.

 

1. первый с рут паролем на cpanel - работает

2. второй cpanel без указанного рут пароля

3. третий directadmin без указанного рут пароля.

 

для 2,3 серверов имеем схожую проблему:

 

http://monitoring/index.php?server=3

 

 

400BadRequest

nginx

 

Warning: Invalid argument supplied for foreach() in /var/www/html/index.php on line 586

24-10-2010 10:25:42: MySQL is Failed : FAIL!

 

 

Какой запрос шлет скрипт, что наши сервера на него отвечают Badrequest?

 

если дать скрипту рут паро

 

ль - то все будет нормально, но хотелось бы мониторить сервера без рут пасов. там же собственно запрос по http скрипта...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

есть возможность простого мониторинга по URL вида http://server:80 (подобный URL же задается в настройках сервера?) БЕЗ дополнительных запросов на дургие URL.

 

также мониторить по пингу было бы тоже неплохо..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

есть возможность простого мониторинга по URL вида http://server:80 (подобный URL же задается в настройках сервера?) БЕЗ дополнительных запросов на дургие URL.

 

также мониторить по пингу было бы тоже неплохо..

+1, Алексей уже же предлагал это сделать, хотя бы за доп. плату..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

есть возможность простого мониторинга по URL вида http://server:80 (подобный URL же задается в настройках сервера?) БЕЗ дополнительных запросов на дургие URL.

 

также мониторить по пингу было бы тоже неплохо..

См. информацию в документации, все можно сделать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вопрос:

 

запрос вида

 

http://monitoring/index.php?server=4

 

31-10-2010 12:37:50: The Server IP Does Work Stably!

& STATUS CHECK

Warning: file(http://...@IP:2086/scripts/servup) [function.file]: failed to open stream: Connection refused in /var/www/html/index.php on line 672

 

Warning: Invalid argument supplied for foreach() in /var/www/html/index.php on line 674

 

как мониторить БЕЗ STATUS CHECK?

 

В настройках этого сервера стоит NO для обоих полей

Проверка нагрузки NO

Проверка почтовой очереди.

 

А в ридми указано

index.php ?server=1 – стандартная проверка (только http и MySQL).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблему решил исправив URL с вида http://domain на http://domain/

nginx установлен на сервере с uptime checker?

nginx установлен на проверяемом сервере?

 

вопрос:

 

запрос вида

 

http://monitoring/index.php?server=4

 

31-10-2010 12:37:50: The Server IP Does Work Stably!

& STATUS CHECK

Warning: file(http://...@IP:2086/scripts/servup) [function.file]: failed to open stream: Connection refused in /var/www/html/index.php on line 672

 

Warning: Invalid argument supplied for foreach() in /var/www/html/index.php on line 674

 

как мониторить БЕЗ STATUS CHECK?

 

В настройках этого сервера стоит NO для обоих полей

Проверка нагрузки NO

Проверка почтовой очереди.

 

А в ридми указано

index.php ?server=1 – стандартная проверка (только http и MySQL).

loadusage не должно проверяться при "Проверка нагрузки: NO".

 

Предоставьте данные доступа в админку uptime checker на admin @ advanta.org. При возможности предоставьте и данные доступа FTP, велика вероятность, что понадобятся.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

nginx установлен на сервере с uptime checker?

nginx установлен на проверяемом сервере?

 

nginx стоит на серверах который мониторим.

 

>loadusage не должно проверяться при "Проверка нагрузки: NO".

 

тем не менее проверил еще раз - это факт.

 

Вы это можете также воспроизвести у себя - для всех серверов какое бы значение не стояло в поле Проверка нагрузки: - происходит проверка нагрузки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Она происходит постоянно или с какой-то периодичностью запусков?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

пробовал раз 40 запускать через браузер

 

каждый раз

 

09-11-2010 19:14:28: The Server IP Does Work Stably!

& STATUS CHECK

Warning: file(http://...@IP:2086/scripts/servu

 

при этом

 

Проверка нагрузки (NO: OFF): NO

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Забадал скрипт: вчера начал постоянно сообщать в таком виде о проблемах на сервере:

 

IP

CPU: Server load</td> <td>0.64 VS 10

MEM: Memory Used</td> <td>25.36% (2052964 of 8096692)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>Swap Used</td> <td>0.15% (6488 of 4194296)</td> <td><img src="/green-status.gif" /></td></tr></table><br /><h3>Disk information</h3><table class="datatable brick" width="100%"><tr> <th>Device</th> <th>Mount point</th> <th>Usage</th> <th></th> <th></th></tr><tr> <td>/dev/root</td> <td>/</td> <td>10.21% (2331436 of 22836532)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda1</td> <td>/boot</td> <td>23.71% (23970 of 101086)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda3</td> <td>/usr</td> <td>66.92% (8159324 of 12192636)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda5</td> <td>/var</td> <td>74.39% (9069724 of 12192608)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda6</td> <td>/tmp</td> <td>4.26% (43404 of 1019208)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda7</td> <td>/home</td> <td>9.06% (167088004 of 1843998872)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sdb1</td> <td>/drive_sdb</td> <td>25.12% (241483320 of 961432072)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sdc1</td> <td>/drive_sdc</td> <td>3.89% (37407008 of 961432072)</td> <td><img src="/green-status.gif" /></td></tr></table></div></div></body></html><!-- Web Host Manager 11.28.27 [] © cPanel, Inc. 1997-2010 http://cpanel.net/ Unauthorized copying is prohibited --> VS 90

apache: OK (L)

bind: OK (L)

exim: OK (L)

mysql: OK (L)

Server load</td> <td>0.64>20 or Memory Used</td> <td>25.36% (2052964 of 8096692)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>Swap Used</td> <td>0.15% (6488 of 4194296)</td> <td><img src="/green-status.gif" /></td></tr></table><br /><h3>Disk information</h3><table class="datatable brick" width="100%"><tr> <th>Device</th> <th>Mount point</th> <th>Usage</th> <th></th> <th></th></tr><tr> <td>/dev/root</td> <td>/</td> <td>10.21% (2331436 of 22836532)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda1</td> <td>/boot</td> <td>23.71% (23970 of 101086)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda3</td> <td>/usr</td> <td>66.92% (8159324 of 12192636)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda5</td> <td>/var</td> <td>74.39% (9069724 of 12192608)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda6</td> <td>/tmp</td> <td>4.26% (43404 of 1019208)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sda7</td> <td>/home</td> <td>9.06% (167088004 of 1843998872)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sdb1</td> <td>/drive_sdb</td> <td>25.12% (241483320 of 961432072)</td> <td><img src="/green-status.gif" /></td></tr><tr> <td>/dev/sdc1</td> <td>/drive_sdc</td> <td>3.89% (37407008 of 961432072)</td> <td><img src="/green-status.gif" /></td></tr></table></div></div></body></html><!-- Web Host Manager 11.28.27 [] © cPanel, Inc. 1997-2010 http://cpanel.net/ Unauthorized copying is prohibited -->>90

SMS:0,1

 

 

Я вроде человек нормальный, но увидеть на что именно он здесь ругается не могу. При этом сервер находится в нормальном состоянии.

 

Поясните, прошу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

пробовал раз 40 запускать через браузер

 

каждый раз

 

09-11-2010 19:14:28: The Server IP Does Work Stably!

& STATUS CHECK

Warning: file(http://...@IP:2086/scripts/servu

 

при этом

 

Проверка нагрузки (NO: OFF): NO

У Вас в настройках несколько серверов? Проверьте, может не у того настройку установили или т.п. ляпы.

 

Забадал скрипт: вчера начал постоянно сообщать в таком виде о проблемах на сервере:

 

IP

CPU: Server load</td> <td>0.64 VS 10

 

 

Я вроде человек нормальный, но увидеть на что именно он здесь ругается не могу. При этом сервер находится в нормальном состоянии.

 

Поясните, прошу.

WHM обновилась вчера? У нас пока подобная ошибка не вылезла (автоматическое обновление до последний Stable).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

>У Вас в настройках несколько серверов? Проверьте, может не у того настройку установили или т.п. ляпы.

 

Уберите для одного из своих серверов пароль в конфиге и запустите проверку - у вас будет тоже самое.

 

 

>WHM обновилась вчера? У нас пока подобная ошибка не вылезла (автоматическое обновление до последний Stable).

 

обновилась, но также скрипт упорно рапортует эту хрень.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

>У Вас в настройках несколько серверов? Проверьте, может не у того настройку установили или т.п. ляпы.

 

Уберите для одного из своих серверов пароль в конфиге и запустите проверку - у вас будет тоже самое.

Обновил архив. Сообщите, если ошибка все еще имеет место быть.

 

>WHM обновилась вчера? У нас пока подобная ошибка не вылезла (автоматическое обновление до последний Stable).

 

обновилась, но также скрипт упорно рапортует эту хрень.

Обновитесь до последней stable.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

>Обновил архив. Сообщите, если ошибка все еще имеет место быть.

 

проверю в ближ. время.

 

>Обновитесь до последней stable.

 

У нас RELEASE ветка, последняя версия. Нужна именно STABLE? Не уверен...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
У нас RELEASE ветка, последняя версия. Нужна именно STABLE? Не уверен...

Обновите на stable, после чего сообщите, если ошибка все еще будет иметь место быть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

сменили ветку cpanel на stable - по icq скрипт перестал уведомлять но в логах все равно что-то несусветное отображается.

 

также прошу уточнить - шлет ли скрипт по каким-либо причинам команды на ребут сервера (именно команды через whm, а не тикет в ДЦ) ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
сменили ветку cpanel на stable - по icq скрипт перестал уведомлять но в логах все равно что-то несусветное отображается.

WHM 11.26.20 подобных проблем не наблюдаем.

Из-за cPanel скрипт перестать отправлять сообщения ICQ не должен был. Полагаю, что причина явно в чем-то другом.

 

также прошу уточнить - шлет ли скрипт по каким-либо причинам команды на ребут сервера (именно команды через whm, а не тикет в ДЦ) ?

Нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

×