Перейти к содержанию
Форумы
stanleyloud

Ошибка синтаксиса

Рекомендуемые сообщения

Внезапно стала вылезать ошибка

Parse error: syntax error, unexpected '?' in /home/ххххххх/public_html/хххххх/my/panel.php on line 2

 

К файлам скрипта не притрагивались.

 

Обновили скрипт до последней версии, а ошибка всё равно осталась осталась.

 

В чём проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

На сервере ничего не трогали?

Очень похоже, что Ваш сервер не воспринимает защифрованный zend guard файл (возможно у Вас она сервере при обновлении php или других работах отвалился zend loader).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нет, к серверу не притрагивались. Настройки не меняли. Zend работал хорошо, сам скрипт тоже функционировал. Но затем внезапно стало выдавать данную ошибку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вы писали, что

 

Обновили скрипт до последней версии

 

Как именно обновили? Через спец. ф-ию в скрипте? Обновите файлы вручную по FTP. Возможно, при автоматическом обновлении файлов сервер неправильно распаковал файлы из архива или что-либо еще.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сама ошибка появилась ещё до обновления.

Обновление производили заменой старых файлов скрипта новыми (за исключением файла config.php). После обновления ошибка осталась.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если до обновления, то однозначно на сервере что-то слетело. Были уже подобные ситуации у других клиентов. Решалось пинанием системных администраторов серверов :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

×